총 게시물 39,204건, 최근 1 건 안내 RSS 글쓰기
이전글  다음글  목록 글쓰기
[안드로이드]

이클립스 SDK 26 버전 적용 관련 문의

글쓴이 : 엣센스 날짜 : 2018-09-18 (화) 15:15 조회 : 1096
글주소 : http://www.androidside.com/B49/170365
 
  본디스크 이클립스
최신영화, 드라마, 예능프로 초고속다운로드, 스마트폰 바로보기, 이클립스
www.bondisk.co
  위메프 이클립스
역대급 할인쿠폰! 즉시할인, 식품/리빙/패션 추가혜택, 이클립스
www.wemakeprice.com/
  굿다운로드 이클립스 씨네폭스
이클립스, HD고화질 영화, 애니, TV시리즈 합법다운, 스마트폰 감상.
clean.cinefox.com
신청하기


안드로이드, 자바 그리고 다양한 질문에 대해 성실히 답해드립니다. Q&A Jang

안녕하세요
안드로이드 오레오 이상에서는 백그라운드 서비스 때문에 JobIntentService를 사용해야된다고해서
해당 서비스를 스튜디오에서 구현을 해서 라이브러리 형식으로 만들었습니다.
이걸 이제 이클립스에서 사용을 할려고하는데 
혹시 이클립스에서 support-v4 라이브러리 26버전 을 사용할수 있을까요?
현재 support-v4 라이브러리와 support-compat 라이브러리를 사용하면 JobIntentService 는 임폴트가 되는데
앱 빌드 시 두 라이브러리가 충돌이 나서 빌드가 안되네요..
이클립스에서 support-v4 라이브러리를 SDK 26 버전용으로 받을수 있거나 다른 방법이 있으면
조언좀 부탁드립니다
감사합니다,



질문자가 자신의 포인트 5 점을 걸었습니다.
답변하시면 포인트 2을, 답변이 채택되면 포인트 4을 드립니다.

질문답변 게시판에서 궁금한 사항을 해결하셨다면, 애써 답변해주신 분께 잘 되었다고 따뜻한 댓글 한마디 남겨주세요.
그리고 답변해주신 분의 글을 '추천' 해주세요.
추천받으신 분에게 1포인트가, 추천하신 분에게도 1포인트가 적립됩니다. ^^

OSKiller 2018-09-18 (화) 16:45
글쎼요...
이클립스는 공식지원을 끊은지 오래되서 되려나 모르겠네요
이시점에서 앱을 굳이 이클립스로 개발 하려는 것부터가 좀 ㄸㄷ
댓글주소 추천 0 반대 0
     
     
엣센스 2018-09-18 (화) 16:58
[@OSKiller]
업체가 있는데 지금 당장은 이클립스상태이며 스튜디오로  변환하고 테스트하는데 좀 오래걸릴거 같다고 이야기를 하셔셔요 ㅠㅠ 당장 플레이스토어에는 SDK26 을 11월부터는 무조건 올려야되서 해당 SDK26 을 올리면 오레오에서 백그라운드 제한 떄문에 저 클래스가 필요한상황입니다.. 구글 쪽에 문의를 해봐도 이클립스여서 기술지원이 불가능하다고 답변을 받아서 혹시나 이런 상황을 겪으셔서 해결하신분이 있나 해서요..

댓글주소 추천 0 반대 0
이전글  다음글  목록 글쓰기

 


Copyright ⓒ www.androidside.com. All rights reserved.
채팅 권한: 글쓰기 1개
2레벨 이상만 대화 가능
공개 채팅: 평일 !(9시 ~ 17시),토,일
안사2 변경사항 보러가기 챗방이 잘 안보이면 크롬에서 접속해주세요
챗방 숨기기 |  챗방 보이기